股票六六论坛

 找回密码
 立即注册
搜索
热搜: 活动 交友 discuz
股票六六论坛 门户 查看主题

请高手帮忙写个选股公式

发布者: 黄三 | 发布时间: 2018-7-11 09:15| 查看数: 1387| 评论数: 7|帖子模式

马上注册,结交更多股友,享用更多功能,让你轻松玩转股票

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
本帖最后由 黄三 于 2018-7-11 22:00 编辑

请高手帮忙写个选股公式,谢谢!
指标用法:
1,MACD反身向上选股:TT=1.00
2,顶背离时画绿线,底背离时划红线。
2,以上公式放牛郎已测试,可以使用,放牛郎不再解答其他问题。


DIFF:EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:EMA(DIFF,9);
MACD:2*(DIFF-DEA), COLORSTICK;
WW:=DEA>REF(DEA,1);
DD:=CROSS(DIFF,REF(DIFF,1));
TT:WW AND DD;
DRAWICON(CROSS(DIFF,DEA),DEA,1);
低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;
STICKLINE(低位金叉,0,0.3,8,0),COLORYELLOW;
JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
STICKLINE(二次金叉,0,0.2,8,0),COLORFF80FF;
DRAWICON(二次金叉,DEA*0.9,1) ;
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
底背离:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);
STICKLINE(底背离,0,0.1,8,0),COLORRED;
DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORRED,LINETHICK2;
A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);
DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORGREEN,LINETHICK2;
DRAWICON(CROSS(DIFF,DEA),DEA,1);
反身向上.gif

最新评论

大麦粥 发表于 2020-3-22 13:38:18
这个指标能公开下吗?能指导下如何使用吗?谢谢
韩霄雯 发表于 2019-11-28 17:29:55
具体公式正确发一下可以吗
韩霄雯 发表于 2019-11-28 17:29:32
怎么导入不了呀
黄三 发表于 2018-7-15 13:46:26
谢谢 六月飞雪老师!

六月飞雪 发表于 2018-7-14 23:13:00
黄三 发表于 2018-7-12 00:05
要底背离低位二次金叉的选股公式,先谢谢了!

DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA), COLORSTICK;
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
底背离:REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);
黄三 发表于 2018-7-12 18:05:40
这个“1,MACD反身向上选股:TT=1.00”要怎么写?
黄三 发表于 2018-7-12 00:05:02
要底背离低位二次金叉的选股公式,先谢谢了!
快速回复 返回顶部 返回列表