股票六六论坛

 找回密码
 立即注册
搜索
热搜: 活动 交友 discuz
股票六六论坛 门户 查看主题

请老师写一个股价上穿三线时预警的公式,通达信。谢谢。

发布者: 均线之美 | 发布时间: 2019-6-21 13:40| 查看数: 733| 评论数: 1|帖子模式

马上注册,结交更多股友,享用更多功能,让你轻松玩转股票

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
本帖最后由 均线之美 于 2019-6-21 13:47 编辑

源码:N:=26;
P:=2;

MID : MA(CLOSE,N);

UPPER: MID + P*STD(CLOSE,N);

LOWER: MID - P*STD(CLOSE,N);

MA3:MA(CLOSE,3),COLOR0099FF;

BBI:(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4,COLORRED;

DRAWTEXT(ISLASTBAR=1,BBI*1.007,'BBI多空指数'),COLORRED;

DRAWICON(CROSS(MA3,BBI),BBI*0.99,1);

DRAWICON(CROSS(BBI,MID ),BBI*0.99,9);

RSV2:=(CLOSE-LLV(LOW,89))/(HHV(HIGH,89)-LLV(LOW,89))*100;

N2:=27;

RSV1:=(CLOSE-LLV(LOW,N2))/(HHV(HIGH,N2)-LLV(LOW,N2))*100;

中K:=SMA(RSV1,5,1);

中D:=SMA(中K,10,1);

C_D1:=(3*C+2*O+L+H)/7;

WMA5:=(5*C_D1+4*REF(C_D1 ,1 )+3*REF(C_D1 ,2 )+2*REF(C_D1 ,3 )+REF(C_D1 ,4 ))/15;

C_D2:=REVERSE(C_D1)+2*WMA5;

红箭头:=CROSS(WMA5,C_D2*0.997);

K1:=SMA(RSV1,5,1);

D1:=SMA(K1,5,1);

J1:=3*K1-2*D1;

AA1:=EMA(J1,5);

AA2:=REF(AA1,1);

股价以任何形势上穿都行,跌破再收上来,跳空。只要能上穿三线就预警。三线无任何排列要求。谢谢。

tdxjietu5.JPG

最新评论

小白龙 发表于 2020-6-13 20:47:51
出现小钱袋图标选股如下:

N:=26;
P:=2;
MID:=MA(CLOSE,N);
UPPER:=MID + P*STD(CLOSE,N);
LOWER:=MID - P*STD(CLOSE,N);
MA3:=MA(CLOSE,3),COLOR0099FF;
BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4,COLORRED;
XG:CROSS(BBI,MID ) AND BBI*0.99 ;
快速回复 返回顶部 返回列表